Assalamu'alaikum. Selamat Datang di blog saya yang berjudul Peace, Love and Believe ini. Semoga kita bisa berbagi tentang apa saja.

Kamis, 17 Oktober 2013

Konfigurasi Sederhana IP Nat Outside Source Command



Konfigurasi Sederhana menggunakan Command IP Nat Outside Source

Topology jaringan yang digunakan :

Ketika kita melakukan Ping dari interface Loopback 0 router R1 (172.16.88.1) dengan destinasi interface Loopback 0 router R3 (171.68.1.1), maka yang terjadi adalah :

Router R1 memforward paket ke router R2 karena sebelummya telah dikonfigurasi default route pada router R1. Pada outside interface router R2, paket memiliki source address (SA) 172.16.88.1 dan destination address (DA) 171.68.1.1. Karena SA di permit secara explicit dalam access-list yang kemudian digunakan sebagai source IP Nat, SA tersebut akan ditranslasi dengan menggunakan address yang ada dalam Nat Pool. Ingat bahwa command ip nat outside source list akan merujuk pada Nat Pool sebagai address hasil translasinya. Pada kasus ini, address ditranslasi menjadi 171.68.16.10 dimana IP ini adalah IP pertama yang available di Nat Pool. Setelah translasi, router R2 melihat destination address di dalam routing table-nya, dan kemudian me-routing-kan paket tersebut sesuai tujuannya. Router R3 melihat paket datang melalui incoming interface-nya (interface E0). Paket tersebut memiliki SA 171.68.16.10 dan DA 171.68.1.1. R3 kemudian merespon dengan mengirim ICMP echo reply ke 171.68.16.10. JIka address 171.68.16.10 tidak ada di routing table, maka paket tersebut akan di drop. Pada kasus ini, R3 memiliki default route, sehingga R3 mengirim paket ke router R2 menggunakan SA 171.68.1.1 dan DA 171.68.16.10. Router R2 kemudian melihat paket yang datang melalui inside interface-nya tersebut, dan kemudian melakukan pengecekan route menuju 171.68.16.10. Jika router R2 tidak memiliki routing menuju ke alamat tersebut, maka statusnya menjadi unreachable. Namun pada kasus ini router R2 memiliki default route menuju 171.68.16.10, karena adanya penggunaan optional command add-route pada ip nat outside source dimana optional command ini akan menambahkan route menuju host berdasarkan translasi antara outside global address dan outside local address, sehingga router R2 akan mentranslasikan paket kembali menuju 172.16.88.1 melalui outside interface-nya.

Configurations
Router R1
hostname R1
interface Loopback0
 ip address 172.16.88.1 255.255.255.0
interface Serial0
 ip address 172.16.191.254 255.255.255.252
 no ip mroute-cache
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.191.253

Router R2
hostname R2
interface Ethernet1
 ip address 171.68.192.202 255.255.255.0
 ip nat inside
 no ip mroute-cache
 no ip route-cache
interface Serial1
 ip address 172.16.191.253 255.255.255.252
 ip nat outside
 no ip mroute-cache
 no ip route-cache
 clockrate 2000000
ip nat pool Net171 171.68.16.10 171.68.16.254 netmask 255.255.255.0
ip nat outside source list 1 pool Net171 add-route
ip classless
ip route 172.16.88.0 255.255.255.0 172.16.191.254
ip route 171.68.1.0 255.255.255.0 171.68.192.201
access-list 1 permit 172.16.88.0 0.0.0.255

Router R3
hostname R3
interface Loopback0
 ip address 171.68.1.1 255.255.255.0
interface Ethernet0
 ip address 171.68.192.201 255.255.255.0
ip classless
ip route 0.0.0.0 0.0.0.0 171.68.192.202
 
Verifikasi
Show ip nat translations dapat digunakan untuk melakukan pengecekan terhadap hasil translasi,
seperti terlihat di bawah ini : 
R2# show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
--- 171.68.1.1          171.68.1.1         171.68.16.10       172.16.88.1
--- --- 
Output di atas menunjukkan Outside global  address 172.16.88.1 (ip address interface Loopback 0 
router R1) ditranslasikan menjadi Outside local address 171.68.16.10. 
Show ip route juga dapat digunakan untuk mengecek entri routing table, seperti berikut : 
R2# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set 
     171.68.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       171.68.192.0/24 is directly connected, Ethernet1
S       171.68.1.0/24 [1/0] via 171.68.192.201
S       171.68.16.10/32 [1/0] via 172.16.88.1
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
S       172.16.88.0/24 [1/0] via 172.16.191.254
C       172.16.191.252/30 is directly connected, Serial1
 

Pada routing table di atas, terlihat sebuah /32 untuk outside local address 171.68.16.10, dimana 
route tersebut di create karena adanya penggunaan optional command add-route pada command 
ip nat outside source. Route ini digunakan untuk me-routing-kan dan mentranslasikan paket dari 
inside ke outside network.
 
Troubleshoot
Output berikut adalah hasil dari debug ip packet dan debug ip nat pada router R2, ketika secara
bersamaan dilakukan ping dari Router R1 dengan source address interface Loopback 0 
(172.16.88.1) ke interface Loopback 0 (171.68.1.1) router R3. 
*Mar  1 00:02:48.079: NAT*: s=172.16.88.1->171.68.16.10, d=171.68.1.1 [95]
!--- Source address pada paket pertama, tiba dan masuk ke interface outside
ditranslasikan pertama kali
*Mar  1 00:02:48.119: IP: tableid=0, s=171.68.16.10 (Serial1), d=171.68.1.1 (Ethernet1),
routed via RIB
*Mar  1 00:02:48.087: IP: s=171.68.16.10 (Serial1), d=171.68.1.1 (Ethernet1),
g=171.68.192.201, len 100, forward 
!--- Paket ICMP echo request (dengan IP source address yang telah ditranslasi)
diroutingkan dan diforward ke inside interface. 
*Mar  1 00:02:48.095: IP: tableid=0, s=171.68.1.1 (Ethernet1), d=171.68.16.10 (Serial1),
routed via RIB 
!--- Paket ICMP echo reply sampai di interface inside diroutingkan berdasarkan 
destination address-nya.
*Mar  1 00:02:48.099: NAT: s=171.68.1.1, d=171.68.16.10->172.16.88.1 [95] 
!--- Destination address pada paket kemudian ditranslasikan.
*Mar  1 00:02:48.103: IP: s=171.68.1.1 (Ethernet1), d=172.16.88.1 (Serial1),
g=172.16.191.254, len 100, forward 
!--- Peket ICMP echo reply (dengan IP destination address yang telah ditranslasi)
diforward melalui outside interface.
Contoh di atas adalah untuk satu buah paket ICMP, dan akan berulang seperti di atas sesuai
jumlah paket ICMPnya.
 

Tidak ada komentar:

Poskan Komentar