Assalamu'alaikum. Selamat Datang di blog saya yang berjudul Peace, Love and Believe ini. Semoga kita bisa berbagi tentang apa saja.

Kamis, 09 Mei 2013

Source Specific Multicast (SSM)

Jika belum tahu type-type multicast routing, silakan klik disini

Pada lab SSM kali ini, kita akan melakukan filtering source paket dengan join group IGMP versi 3.

Berikut topologinya :

Konfigurasi R1 :

ip multicast-routing

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 ip address 12.12.12.1 255.255.255.0
 ip pim sparse-mode

router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

ip pim rp-address 1.1.1.1


Konfigurasi R2 :

ip multicast-routing

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 ip address 12.12.12.2 255.255.255.0
 ip pim sparse-mode
!
interface Ethernet0/1
 ip address 23.23.23.2 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 225.0.0.1 source 1.1.1.1
 ip igmp version 3
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

ip pim ssm range 1
!
access-list 1 permit 225.0.0.0 0.0.0.255


Konfigurasi R3 :

ip multicast-routing

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 ip address 23.23.23.3 255.255.255.0
 ip pim sparse-mode

router ospf 1
 network 0.0.0.0 255.255.255.255 area 0

ip pim rp-address 1.1.1.1


Verifikasi :

R1#ping 225.0.0.1 source e0/0 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.0.0.1, timeout is 2 seconds:
Packet sent with a source address of 12.12.12.1
.....


Paket di atas tdk dapat mencapai alamat 225.0.0.1 karena sourcenya dibatasi hanya dari ip 1.1.1.1 atau loopback 0 R1.

R1#ping 225.0.0.1 source lo0 re      
R1#ping 225.0.0.1 source lo0 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.0.0.1, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1

Reply to request 0 from 23.23.23.2, 2 ms
Reply to request 0 from 23.23.23.2, 2 ms
Reply to request 1 from 23.23.23.2, 1 ms
Reply to request 1 from 23.23.23.2, 1 ms


Paket dapat reply dari 23.23.23.2 yang melakukan join ke group 225.0.0.1

Tidak ada komentar:

Poskan Komentar